Bugzilla can't authenticate to gmail

Mike Ambrose mike_a at topazsystems.com
Sat Feb 25 00:24:14 UTC 2023

I followed the instructions for installing Bugzilla 5.0.6 on Ubuntu 22.0.4.  There was a little tweaking required for Apache but Bugzilla is now being served by an Ubuntu server.  The big problem is enabling email.  I wanted to use gmail as much easier than setting up our own SMTP server but it fails to authenticate.  Ufw is disabled.

  *   mail_delivery_method: SMTP
  *   mailfrom: new_gmail_address at gmail.com<mailto:new_gmail_address at gmail.com>
  *   smtpserver: smtp.gmail.com:465  (I also tried port 587)
  *   smtp_username: new_gmail_address at gmail.com<mailto:new_gmail_address at gmail.com>
  *   smtp_password: new_gmail_password
  *   smtp_ssl: On
I tested these settings using Thunderbird on the same server and it works. I also tried some things I found on the internet including changing the username spec to user, all to know avail.  The following is what Apache reports:

Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 220 smtp.gmail.com ESMTP m2-20020a056870030200b0016dbf59175bsm95354oaf.47 - gsmtp
Net::SMTP::_SSL=GLOB(0x562c48a326a0)>>> EHLO bugzilla-sw
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 250-smtp.gmail.com at your service, []
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 250-SIZE 35882577
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 250-8BITMIME
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 250-ENHANCEDSTATUSCODES
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 250-PIPELINING
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 250-CHUNKING
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 250 SMTPUTF8
Net::SMTP::_SSL=GLOB(0x562c48a326a0)>>> AUTH LOGIN
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 334 VXNlcm5hbWU6
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< (decoded) Username:
Net::SMTP::_SSL=GLOB(0x562c48a326a0)>>> (decoded) my_gmail at gmail.com<mailto:my_gmail at gmail.com>
Net::SMTP::_SSL=GLOB(0x562c48a326a0)>>> dHB6YnVnc0BnbWFpbC5jb20=
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 334 UGFzc3dvcmQ6
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< (decoded) Password:
Net::SMTP::_SSL=GLOB(0x562c48a326a0)>>> (decoded) my_password
Net::SMTP::_SSL=GLOB(0x562c48a326a0)>>> WXVtIEJ1Z3Mh
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 535-5.7.8 Username and Password not accepted. Learn more at
Net::SMTP::_SSL=GLOB(0x562c48a326a0)<<< 535 5.7.8  https://support.google.com/mail/?p=BadCredentials m2-20020a056870030200b0016dbf59175bsm95354oaf.47 - gsmtp

Does anyone  have an idea what is happening here?


Mike Ambrose
Topaz Systems, Inc

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bugzilla.org/pipermail/support-list/attachments/20230225/21ed0478/attachment.html>

More information about the support-list mailing list