Should Bugzilla 2.18 require Perl 5.6.1?

David Miller justdave at
Tue May 11 13:33:40 UTC 2004

Jeroen Ruigrok/asmodai wrote:

> -On [20040510 19:52], David Miller (justdave at wrote:
>>I've gotten absolutely zero responses from anyone saying they still need 
>>Perl 5.6.0 support.  We're close enough to releasing 2.18 now, though, 
>>I'm going to go ahead and leave the requirement at 5.6.0 for 2.18, 
>>however we will be dropping 5.6.0 support (requiring a minimum of at 
>>least 5.6.1) for 2.19/2.20.
> Not trying to beat on a dead horse here, so excuse me if I missed
> previous discussions (only now getting back on track with my lists), but
> wouldn't a dependency on 5.8.x not be a better goal?  As far as I
> understood it Unicode support is just not what it should be in 5.6.x and
> given the diverse userbase it would seem more interesting to go that
> route.

Yes, I really want to do that, too.  I remember we got a lot of 
resistance when we dropped 5.005 support for 2.18 (2.16 still supports 
5.00503).  Just remembering that, and knowing that 5.6.1 hasn't 
disappeared all that long ago.  On the other hand, 2.18 with 5.6.0 
support will be around for at least a year, and that's a long time in 
the software world, so requiring 5.8 on the trunk probably wouldn't hurt 
that bad (people who need earlier can just keep using 2.18).

Although working Unicode support (as much as Bugzilla needs) can be 
accomplished with Perl 5.6.1, as long as you don't need to do character 
set conversions.  But inbound email support will likely require charset 
conversions (because we'll need to convert whatever charset the email is 
in to Unicode before putting it in the database).  Any conversion code 
from legacy databases would certainly require 5.8 as well.

Dave Miller      Project Leader, Bugzilla Bug Tracking System   

More information about the developers mailing list