API Design Questions (5)
gerv at mozilla.org
Wed Sep 30 13:28:35 UTC 2009
On 23/09/09 12:14, Gervase Markham wrote:
> Here are some things I've run into when designing the RESTful API.
> Perhaps people could tell me what they think the best option is.
The current list of objects, fields and types for the REST API is here:
Please let me know if anything looks wrong to you.
We have a part-convention of having boolean field names start "is_". But
it's only part at the moment.
So how about the following changes?
* ever_confirmed => is_confirmed ("confirmed", not CONFIRMED :-)
* cc_accessible => is_cc_accessible
* reporter_accessible => is_reporter_accessible
(or perhaps is_accessible_by_cc/reporter, or is_visible_to_cc/reporter?)
dev-apps-bugzilla mailing list
dev-apps-bugzilla at lists.mozilla.org
More information about the developers