Bugzilla::WebService::Bug - where is the datetime_format() sub?

JA Robson arbingersys at gmail.com
Fri May 8 19:08:12 UTC 2009

Hi, I'm trying out the web services demo script, and I've discovered
something I can't quite figure out.

I tried the following:

./contrib/bz_webservice_demo.pl --uri
http://localhost/bugzilla/xmlrpc.cgi --bug_id=4

and get:

Connecting to a Bugzilla of version 3.5.
Bugzilla's timezone is -0600.
-32000 Can't locate object method "datetime_format" via package
"Bugzilla::WebService::Bug" at Bugzilla/WebService.pm line 39.
 in SOAP call near ./contrib/bz_webservice_demo.pl line 272.

I've ack'ed the source, tried to locate a module that this sub is
magically being inherited from, but have found nothing. If you comment
out line 39 below from WebService.pm, things work.

 36 sub type {
 37     my ($self, $type, $value) = @_;
 38     if ($type eq 'dateTime') {
 39         $value = $self->datetime_format($value);
 40     }
 41     return XMLRPC::Data->type($type)->value($value);
 42 }

So where is datetime_format()? What am I missing?

Thanks, James

More information about the developers mailing list