Should Bugzilla 2.18 require Perl 5.6.1?
justdave at bugzilla.org
Mon May 10 17:42:34 UTC 2004
David Miller wrote:
> In hunting down various bugs, we've run into some more taint-related
> problems that are essentially bugs in Perl 5.6.0 that were fixed in
> 5.6.1. There are ways to work around them, but they're not fun.
> How many people are still using Perl 5.6.0 or older?
> Bugzilla 2.16.x currently requires Perl 5.00503 or newer. The 2.17
> branch (which will soon be 2.18) currently already requires Perl 5.6.0
> or newer. Would it hurt too many people if we go the extra step up to
> require Perl 5.6.1?
> I'm not aware of any distros still shipping 5.6.0. Mac OS X was the
> last one I knew of that was still shipping Perl 5.6.0, and they're
> shipping 5.8.1 now.
I've gotten absolutely zero responses from anyone saying they still need
Perl 5.6.0 support. We're close enough to releasing 2.18 now, though,
I'm going to go ahead and leave the requirement at 5.6.0 for 2.18,
however we will be dropping 5.6.0 support (requiring a minimum of at
least 5.6.1) for 2.19/2.20.
Dave Miller Project Leader, Bugzilla Bug Tracking System
More information about the developers