Parameter names - bug 155628
myk at mozilla.org
Tue Dec 21 07:20:33 UTC 2004
Shane H. W. Travis wrote:
>This is the point I really wanted to address -- the 'aliases' thing.
>As I understand it (and I submit as given that my understanding may be
>faulty), aliases are an indirect way of referring to an underlying parameter
>so that they so that they can be referred to in a more user-frendly manner.
>For example "commentonclose" could be aliased to "Require a comment when a
>bug is closed."
Actually, aliases are a way of making "commentonclose" continue to work
after the param has been renamed to "comment_on_close", so that custom
code which uses "commentonclose" doesn't break when an installation
upgrades to a version of Bugzilla which has changed the name of the
parameter to the underscore-separated version.
>Anyway, thank you to *everyone* who participated in the discussion. Dave has
>indicated that he'll make a go/no-go decision sometime today, in case anyone
>has anything else to say.
Dave, if you're considering rejecting this proposal because of the
volume of code being changed and the consequent impact on pending
patches, consider approving at least changing of the names with aliases
so that the old names still work. Then Bugzilla code could be updated
over time to use the new names without an uber-patch that does it all at
More information about the developers