Parameter names - bug 155628
gerv at mozilla.org
Fri Dec 17 23:10:48 UTC 2004
Shane H. W. Travis wrote:
> Parameter names consisting of many strung-together words are hard to read,
> especially if English is not your first language.
To clarify: you mean parameters as in Param() and editparams.cgi, not
random parameters to CGIs like query.cgi?product=Foo&component=Bar?
> This sort of kicks the legs out from under the 'ease of user use' argument
> that was presented as part of the reason for doing 155628. What I'm
> wondering is this: is the clean-up of the code enough reason to go ahead
> with doing it *anyway*?
I'd say no. The computer just sees them as unique values, and
programmers mostly see them that way as well. All of the current team
seem to have good English.
> One acknowledged downside is that while I can make sure I change all the
> instances in code on the trunk, I can't change param names in code we didn't
Indeed. And I would say the remaining gain isn't worth this pain.
Of course, you could make aliases, so a particular param could be
referred to by two or more values, and canonicalised at the interface
(probably the Param() call). That would improve usability for developers
and customisers without breaking anything.
More information about the developers