Should Bugzilla 2.18 require Perl 5.6.1?

David Miller justdave at
Tue Apr 27 04:42:40 UTC 2004

In hunting down various bugs, we've run into some more taint-related 
problems that are essentially bugs in Perl 5.6.0 that were fixed in 
5.6.1.  There are ways to work around them, but they're not fun.

How many people are still using Perl 5.6.0 or older?

Bugzilla 2.16.x currently requires Perl 5.00503 or newer.  The 2.17 
branch (which will soon be 2.18) currently already requires Perl 5.6.0 
or newer.  Would it hurt too many people if we go the extra step up to 
require Perl 5.6.1?

I'm not aware of any distros still shipping 5.6.0.  Mac OS X was the 
last one I knew of that was still shipping Perl 5.6.0, and they're 
shipping 5.8.1 now.

Dave Miller      Project Leader, Bugzilla Bug Tracking System   

More information about the developers mailing list