More custom field revisions

Jon Wilmoth JWilmoth at starbucks.com
Mon Apr 21 20:53:29 UTC 2003


I've attached example of the admin screen in an attempt to "simplify"
what was already there and also adds a couple of things present in the
spec that weren't present on the ui.

On the db structure:

1)Shouldn't custom_fields.project be an integer foreign key?  
2)Wouldn't the custom_fields.field_id be the PK?
3)Shouldn't custom_field_defs have a "required" Boolean column?
4)Perhaps renaming custom_fields.field_index to
custom_fields.display_order to be more intention revealing.
5)Perhaps rename custom_field_defs.field_name to
custom_field_defs.ui_label to be more intention revealing.

Perhaps a validation table as well?  If so, the "edit" section of the
admin screen I've attached would have to be dynamic according to the
field type.

custom_field_constraints
------------------------
constraint_id primary key,
field_id integer not null,
min integer,
min_error_code tinytext,
max integer,
max_error_code tinytext,
mask tinytext,
mask_error_code tinytext,
...?
...?

This table would define the additional constraints to enforce on a field
value (probably more applicable for open text box type fields) before
saving to the db.  The "_error_code" field would refer to a template
variable defined in "global/error_codes.html.tmpl".  Mask could be a
regular expression outlining for example a date format.

-----Original Message-----
From: Sean McAfee [mailto:etzwane at schwag.org] 
Sent: Monday, April 21, 2003 1:08 AM
To: developers at bugzilla.org
Subject: More custom field revisions

Hi, folks--

Well, there've been no responses to my custom field comments of a week
ago,
which I will optimistically interpret as a general endorsement.

Here are some additional revisions.  The major addition to the
requirements
document is a description of a custom fields administrative interface,
an
example of which can be seen in the attached file cfadmin.html.  The
custom
fields schema, contained in the design document, has been updated to
account
for per-project field ordering.

Let me know what you think.  Thanks.

-- 
Sean McAfee -- etzwane at schwag.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bugzilla.org/pipermail/developers/attachments/20030421/1d0fcc61/attachment.html>


More information about the developers mailing list